Trouble getting DOT unlocked and off Polkadot.js

I’m such a newb it’s embarrasing, and I think I have multiple levels of issues going on, so I haven’t been able to find what I need.

  1. I figured out how to get my DOT to the point where I could nominate.
  2. I nominated, but it seemed like nothing was happening due to validators being inactive (I think.)
  3. I decide to forget this whole thing, to remove my dot, and just stake on Kraken.
  4. So far I’ve clicked “Stop” and “Unbond” (whatever that means). Dont recall what particular screen that occurred on, but was (trying) to follow a tutorial about unstaking if that helps.
  5. Afterwards, I then tried to send my DOT back to my wallet, but it didn’t work.
  6. I took a week off and ignored it.
  7. I tried again today, found the part on my wallet that says my 51 DOT is “locked”.

So…

A) How do I unlock my dot and finally get it off.
B) Is it staked or not? Considering the whole “Stop” / “Unbond” thing.

1 Like

Hi @ThatGuy thanks for your question & sorry you’re having trouble.

So, are you nominating on polkadot.js? Having inactive nominations might mean you nominated validators who don’t have enough stake behind them to be selected to be in the active set. It may also have to do with you not having enough DOT to stake, there is currently a minimum stake that is calculated each new daily cycle but has been staying around 60-100 DOT for a while.

Kraken is a newbie-friendly way to stake. Obviously do your DD as it is custodial and they do not guarantee funds safety. They have a good track record with security, for what it’s worth.

Your funds are locked because they are unbonding which is a process that takes 28 days on Polkadot. So you have 3 more weeks to go. Once the unbonding period is up, you just need to withdraw unbonded funds (staking > account actions > withdraw unbonded funds) for them to be transferrable.

Is it staked or not?

While funds are unbonding they are not staked.

Good luck, let us know if you have other questions!!

@windylion I have the same problem. Thank you for your useful explanations. I just need a confirmation. When I go to Staking → Account action, the Reward column is written “Staked”. Are my fund unbounding or not? I did the following operation staking > account actions > withdraw unbonded funds with my ledger but not sure it worked fine.
Thank you for your confirmation. Best regards,

1 Like

Hey @samnovember welcome to the forum :slight_smile:

To check if your funds are unbonding, go to the Accounts > accounts UI and click the little dropdown arrow next to your account balance:

Screenshot (554)

You can hover over the adjacent icons to see more information about what actions the funds may be locked in, or how much time is left in the unbonding process.

Thanks a lot @windylion the funds were surprisingly not unbounding. Now it’s good and I can see the icons with the remaining time. Hope it won’t crash the next 28 days :smile:

1 Like

Im so sorry for the late reply. I had gotten so fed up with it that I tuned it out for a month (which the 28 days is now over consequently). But THANK YOU for the help!

However now when I click Withdraw Unbonded, I get an error that says, “staking.withdrawUnbonded Spec version not supported”.

Any ideas?

1 Like

Hey @ThatGuy no worries, I’m not familiar with that one; maybe you need to update your metadata (settings > metadata)

If that doesn’t work I’d ask in the community discord - someone there will be able to fix you up.

Thanks for the help! Will take advice.

I don’t see any sort of “Update” option on this page…? Am I supposed to do something with the QR code perhaps? Screen Shot 2021-02-28 at 5.02.42 AM|690x292

1 Like

P.S. (And more embarassment)

I’m only 1/2 step above Discord illiterate. Like, I kind of know what it is. I tried to select Join server but it says I need an invite code. Don’t suppose you can help me with that as well?

Thanks in advance!

1 Like

No worries! It’s a learning curve for all of us.

Am I supposed to do something with the QR code perhaps?

Nope, looks like you’re up to date.

Are you using Ledger as a wallet by any chance? I found this article in the support archive.

If that’s not the issue, maybe try accessing the discord from the community link tree. You can also try the community Element chat, lots of knowledgeable folks there as well.

This looks like it was at least part of the problem. However now it’s saying “staking.withdrawUnbonded queued” and has the pink spinning ball that’s been spinning about 20 minutes so far. Is this normal?

1 Like

Oh wait… Lol, I re-tried and looks like I forgot to confirm on ledger… Geez…

1 Like

GEEZ… Okay… So now I’m getting THESE errors. This is so frustrating. I just want to get my dot off this thing.

1 Like

Hey, glad the ledger component is sorted out.

Did you issue the unbonding command late in the day? According the wiki:

Because certain user actions, like changing nominations, can change the outcome of the Phragmén election, the system forbids calls to these functions for the last quarter of the session before an era change. These functions are not permitted:

withdrawUnbonded

So try earlier in the day :slight_smile:

Hi,

sorry to hijack this thread but I’m having trouble with my staking as well and hoping you can help me as well. I am currently stuck at my tokens being locked and bonded but however have an inactive nominator. I think my amount was too small to be staked however, I am trying to get them out now but when I try to STOP or Unbond my tokens it says, “The account does not have enough free funds (excluding locked/bonded/reserved) available to cover the transaction fees without dropping the balance below the account existential amount.” I have set up 2 accounts, one stash and one controller. My controller account currently has 1 DOT so I think that enough for the fees, right? Please help me in getting my tokens out and back to my exchange. Thank you!!

1 Like

Hi @vlam welcome to the forum!

Actually you need to have enough DOT so AFTER fees you will have at least one DOT left in your controller account. Can you try topping up your controller a bit, then let us know if that solves your problem?